Vaš strežnik deluje na različici PHP 5.1.6, WordPress 4.0 pa zahteva najmanj 5.2.4.